首页 > 动手实验室 > 华为路由器配置DHCP和NAT,实现用户访问Internet公网
2019
09-19

华为路由器配置DHCP和NAT,实现用户访问Internet公网

组网需求

Router作为某企业出口网关,配置DHCP和NAT,实现用户动态获取IP地址并访问Internet公网。

网络规划

该企业包括两个部门A和B,分别为部门A和B内终端规划两个地址网段:10.10.1.0/25和10.10.1.128/25,网关地址分别为10.10.1.1/25和10.10.1.129/25。

部门A内PC为办公终端,地址租用期限为30天,域名为huawei.com,DNS服务器地址为10.10.1.2。

部门B内大部分是出差人员所用便携机,地址租用期限为2天,域名为huawei.com,DNS服务器地址为10.10.1.2。

企业内地址规划为私网地址,且需要访问Internet公网,因此,需要通过配置NAT实现私网地址到公网地址的转换。

连接Router出接口GE0/0/3的对端IP地址为200.100.1.1/24。

华为路由器配置DHCP和NAT,实现用户访问Internet公网 - 第1张  | 鹿鸣天涯

操作步骤

Router上的配置
#
sysname Router  //修改设备名称
#
dhcp enable //使能DHCP功能
#
acl number 2000  //配置允许进行NAT转换的内网地址段10.10.1.0/24
rule 5 permit source 10.10.1.0 0.0.0.255
#
ip pool ip-pool1
gateway-list 10.10.1.1 //配置网关地址
network 10.10.1.0 mask 255.255.255.128 //配置全局地址池可动态分配的IP地址范围
excluded-ip-address 10.10.1.2 //配置地址池中10.10.1.2不参与自动分配
dns-list 10.10.1.2 //配置DHCP客户端使用的DNS服务器的IP地址
lease day 30 hour 0 minute 0 //配置IP地址租期为30天
domain-name huawei.com //配置域名为huawei.com
#
ip pool ip-pool2
gateway-list 10.10.1.129 //配置网关地址
network 10.10.1.128 mask 255.255.255.128 //配置全局地址池可动态分配的IP地址范围
dns-list 10.10.1.2 //配置DHCP客户端使用的DNS服务器的IP地址
lease day 2 hour 0 minute 0 //配置IP地址租期为2天
domain-name huawei.com //配置域名为huawei.com
#
interface GigabitEthernet0/0/1
ip address 10.10.1.1 255.255.255.128
dhcp select global //接口工作在全局地址池模式
#
interface GigabitEthernet0/0/2
ip address 10.10.1.129 255.255.255.128
dhcp select global //接口工作在全局地址池模式
#
interface GigabitEthernet0/0/3
ip address 200.100.1.2 255.255.255.0
nat outbound 2000  //在出接口GE0/0/3上做Easy IP方式的NAT,实现私网地址到公网地址的转换
#
ip route-static 0.0.0.0 0.0.0.0 200.100.1.1  //配置默认路由,保证出接口到对端路由可达
#
return

验证配置结果

# 在Router上执行命令display ip pool,可以查看IP地址池的分配情况。

执行命令display nat outbound,可以查看GE0/0/3上NAT的配置信息。

配置成功后,终端可以动态获取IP地址,并能访问Internet。

最后编辑:
作者:jacky
这个作者貌似有点懒,什么都没有留下。

留下一个回复

你的email不会被公开。